Cannot set BTT as Default Browser from the Setapp Version.

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
I cannot set BTT as the Default Browser from the Setapp Version of BTT (M1 Mac, Monterey).
As the Bundle Identifier in the App is missing the -Setapp suffix, I think this might be the issue.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro (16-inch, 2021), M1 Max
  • macOS version: macOS 12.0.1
  • BetterTouchTool version: (please post the exact version - not just "the latest one")
    3.624 1780
    Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

You are right, this will be fixed soon.

(It would be much better if Setapp would allow me to use the same bundle identifier as this causes big issues with Shortcuts as well - they can not be shared between the Setapp version and the non-Setapp version. I have asked Setapp about this, but haven't received any response ;-( )

1 Like
Imprint | Privacy Policy