Cannot install 3.581

When I check for Alpha version updates, I get the message: BTT 3.581 is now available—you have 3.401. After updating through a download at Index of /releases, I get the same message. If I run the update through BTT, it will not finish the installation.


I have tried since last year to update. Whether I run "Install Update" or download from Index of /releases and run the download, I still have version 3.401. The "Install Update" gets stuck at two thirds the way through. This has happened repeatedly. I thought that it was a problem of Mojave, but last week I finally upgraded through Catalina to Big Sur and this is still happening. This also means that some commands, such as Clear Notifications, do not work in version 3.401 in Big Sur. I was hoping the update would solve that problem, but BTT will simply not update to 3.581.

MacBook Pro (Retina, 15-inch, Mid 2014)
Processor 2.8 Ghz Quad-Core Intel Core i7
Memory 16 GB 1660 Mhz DDR3

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Sounds like you are running BTT from some protected location where BTT does not have write access. You should make sure it's located in your Applications folder. If it already is, I'd delete it and then download a fresh copy from folivora.ai - Great Tools for your Mac!

Imprint | Privacy Policy