Cannot Get Drag & Drop to Work


#1

I'm trying to drag a photo from Evernote into Quicken.

Intended Steps:

  1. Mouse over transaction in Quicken.
  2. Active keyboard+trackpad trigger.
  3. Store current mouse position.
  4. Cursor moves to pre-determined location (over Evernote preview). Note: Drag & drop from this location works manually without any issues.
  5. Single-left click and hold in order to begin drag.
  6. Mouse returns to stored position.
  7. Single-left click released in order to end drag (i.e. drop the dragged image).

Image of BTT:
https://i.imgur.com/EFOWWCc.png


#2

I don't have Quicken or Evernote, but I just tried your general steps and it seems to work fine here (Dragging a window).

Maybe one of these apps makes some assumptions about how a drag should behave and ignores the synthetic ones created in such a way.


#3

No luck. I decided to run a simple drag & drop scenario to test the sequential actions in BTT - move a file on the desktop. BTT isn't working for me, but I can move the file manually with my trackpad. I recorded a screen capture to demonstrate.

https://youtu.be/gIRF_rnznhY

I then added a few 'delay' actions in order to access each step. I'm I correct in saying that it appears that the mouse is moving back to the saved position prior to the file showing as selected? I recorded a screen capture to demonstrate.

https://youtu.be/MowzqiwsTD0

I'm not sure what I'm doing wrong.

BTT Settings

OS X Trackpad Settings


#4

I turned off my trackpad, connected a generic mouse, populated the gestures in BTT (trackpad section --> mouse section), and re-boot in OS X Safe Mode. I then loaded BTT and tested the actions again = same result. The mouse moves, highlights the file, but fails to drag it to the saved mouse location. I don't know what else to do / check / change.

Gestures
https://i.imgur.com/MgsqQzs.png

Mouse Basic Settings
https://i.imgur.com/uwxSjMM.png


#5

Unfortunately I also don't know, it seems to work fine here ;-(
Which macOS version and BTT version are you using?


#6

OS X 10.14.3
BTT 2.717 (1027)


#7

Interesting Update

As you can see in this video (link below), I still cannot move a file on the desktop; however, I can get an application window to move. If you watch the video closely, you may notice something else too: if the window is selected (blue) when I trigger the gesture, the application window moves as expected without any further action. If, though, the window is not selected (i.e., not blue) when I trigger the gesture, the application window does not move completely by itself - I have to do a manual single-finger tap on my trackpad at the very end for the window to relocate.

https://youtu.be/dWIuq3HMrww


#8

Andreas, any additional thoughts or suggestions? Do you find it odd that I'm able to move application windows with BTT, but not a file on the desktop?
~J


#9

Really hoped BTT would provide the functionality to perform this task. Maybe in the future.