Bugs that are bugging me, #3 (maybe not any more on this one!)

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
Hmmm. I cannot recreate this one again, so it may have been squashed in a recent version. It used to be that deleting multiple actions from a long list of actions would appear to work, but if you went out of the button and back in again, only the first delete had actually been actioned.

I'm not sure if I am exactly recreating the scenario in which it was happening before, but it was happening a lot, and I'm trying to recreate in a copy of the button it happened in, so it seems likely to have been fixed.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Stream Deck for sure, but possibly all.


Device information:

  • Type of Mac: MacBook Pro M1 13" (2020)
  • macOS version: Ventura 13.1
  • BetterTouchTool version: 3.9993 (2193)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Delete one action at a time, then exit the button and return and repeat.