Bugs that are bugging me, #1

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
I'm trying to configure a Stream Deck Toggle On/Off button. When editing the appearance of the off state, particularly when editing SF Symbols parameters, the button keeps reverting to a standard Stream Deck button.

Initially when I hit this bug, it was happening when I select SF Symbol (instead of the default Image option). I realised I was well behind on BTT version, so updated to latest alpha and rebooted. Now it seems to happen when I switch from Monochrome to Hierarchical.

This is making it impossible to style a toggle button, as it keeps reverting to the single appearance model in the GUI. It does seem to retain the On/Off actions.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Stream Deck


Device information:

  • Type of Mac: MacBook Pro M1 13" (2020)
  • macOS version: Ventura 13.1
  • BetterTouchTool version: 3.9993 (2193)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

thanks for reporting!
I currently can't reproduce this here, maybe it's some specific settings that cause this.

Could you go to Help =>> Export Diagnostic Debug Information and send the result to andreas@folivora.ai? I think this will also be helpful for the other issue you reported.

Emailed as requested.