Bug with group opener since last updates when no app is open/active

Since the last big update (and its follow up minor update) for notch bar thingy, my group openers fail to open group, unless I have (any) app active/open on screen.

So basically if the screen is empty, then the group openers do not open the groups.
As soon I open any app, things work again.

My Mac is

BTT is at latest version.
Only Touch Bar settings are used (I do not use notch bar or any other feature of BTT).
The group openers are standard "Open Selected Group" triggers of BTT

I did not try to set up fresh openers/triggers, as I would expect the existing ones to proceed working...

The same issue happens with items shown conditionally by keyboard combinations...

Any hint on how to resolve this?


i’ll look into this later today!

1 Like

I think I'm unable to reproduce this.

Can you post an example of how you use the Touch Bar and the group open triggers?
Is your BTT Touch Bar usually hidden and you just show it for the groups?

If no app is active, this usually means Finder / Desktop is active. Are there any app specific settings for Finder in your BTT?

The group opener is the one highlighted in blue, but it is just one of the triggers not working when no app is open on current screen, the ones I trigger with CMD also do not work.
This worked prior to update, and it is set for "all apps" (thus, since finder is always opened, and because it worked prior... it should work, right?)

I mean, if the button is not set for all apps, it also won't appear when there's no app open. Since I can see the button when there is no app open, it confirms to me that it is set up properly as well.

Does it help if I send you the Set perhaps by email?

Sending the set would be great! (andreas@folivora.ai). Maybe even go to help -> export diagnostic debug info, that data would contain all your BTT settings.

Sent to the email both exports.

To see the issue, you would basically start up BTT, and without any app open on current screen, you should see this on the Touch Bar:

Click the right utmost "three lines" settings thingy, just next to the calendar icon.
It won't open.
Open any app, and it will now open a group when triggered.

Another thing to try that also fails is with the same starting config (no apps open) press CMD or ALT. Distinct TB items should appear, and don't. As soon an app is open, that works too.


Thank you! I think I was able to reproduce this and fix it. Could you verify with version 3.705? (get via check for alpha version updates)

1 Like

This issue seems indeed fixed. I did (quick check only) not see any other issue pop up...

Thanks a lot for the quick adjustment!