BTT Won't open even after reinstall

Describe the bug
This all started when I started getting an error message about my versions not being compatible.

I tried some troubleshooting methods from an old thread where I delete the BTT preference folder and it still didn't work. So I decided to reinstall and see if it would resolve from there.

Now, BTT doesn't appear to open at all. I did this new install and when I clicked the prompt to move BTT to the applications folder, nothing happened. I thought it was weird but I was at least able to move it manually.

Currently, I can try and open it from Finder or the Applications folder and only get the OSX app opening animation, but the app itself isn't actually open. There's no icon on the toolbar and it's not showing up at all in Activity Monitor. I've deleted, reinstalled and restarted my computer and still having issues.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.): OSX

Device information:

  • Type of Mac: Macbook Pro 15 inch (2015)
  • macOS version: Catalina 10.15.2
  • BetterTouchTool version: 3.335

I've had similar issues. I have tried to uninstall several times and it wont seem to open again. I have another Mac and it is still working well on it, so not sure the issue with my laptop. I have a 2013 Macbook Air that is having the issues, FYI.

If BTT doesn't launch at all, try this: