BTT Won't open after importing a preset

Crash Report

BetterTouchTool-2023-06-18-111911.Crash (31.3 KB)

Describe the bug
Added this example notchbar preset from the documentation:

BTT Stopped Working.
I'm on the latest Alpha version: v4.091

*Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Each time I open BTT I get this message.
When It reopens it works, but I can't access the settings...

Device information:

  • Type of Mac: MacBook Pro M1Pro 14" - 16GB/1TB
  • macOS version: Ventura 13.4
  • BetterTouchTool version: v4.091

unfortunately the crashlog is a bit too generic to be helpful.

Could you send the contents of this folder to me? "~/Library/Application Support/BetterTouchTool" (to Then I should be able to reproduce this.

You can also try to enable safe mode with this terminal command, this might allow you to access the BTT UI again to delete the trigger that might cause this - although all functionality will be disabled while safe mode is on:

defaults write com.hegenberg.BetterTouchTool BTTSafeModeEnabled YES

Possibly I have found the issue. Could you try version 4.092?

I've activated the SafeMode, But still can't access the BTT UI.
It shows that SafeMode is Active, but nothing.
The BTT window shows for a second and it crashes!

I'll try to send you the file in a minute.

Did you already try v4.092?

I can't access the App to update.
I still get the crash popup even with SafeMode activated :frowning:

Is it this file ?

Ah, here is a direct link to the update:

The ProcessPrioWatcher is not related, you need to replace the

Okay, I'll update and let you know how it goes!
[When I went to the folder you mentioned, that was the only file I found]

BTT Works now! Thanks
Was it a preset importing issue ?
Can I import a preset now ?

it was a bug in the ui rendering engine that was triggered by some elements in that preset. The preset should already be imported.

(However I need to update the Notch Bar example preset a bit, there have been some changes since I created that preset)

I removed it and imported it again (the MenuBar preset), it worked fine !
Thanks @Andreas_Hegenberg

Update for the floating Menu Notch example or the MenuBar one ?