BTT using significant energy / high CPU load

BTT is listed in apps using significant energy almost all the time.
In system monitor I get:

  • energy impact : 22 ~ 28
  • memory : ~107 MB
  • CPU : 25 ~ 30%

I am running Mojave 10.14.4.Beta on 13in MBP / BTT 2.717 (trial version) with just a default preset loaded with no Touch Bar customization at all. Let me know what files / logs / etc you require to troubleshoot this issue.


you probably have some touch bar script running at a high frequency

//edit: ah sorry I didn't see the part about the default preset

Had the same problem, went back to the former version then it was normal again.

would be great if you could go to the BetterTouchTool about screen and click the export debug info button. This will create a folder called BetterTouchToolDebug on your desktop. Please send that to

However most likely it's some macOS beta issue as I have not had similar reports yet as far as I know.

Debug file sent. I will try other versions of BTT as suggested by Steven and report back.


I am on a macOS beta so that could be the problem, but it's not with this version that I am running now......

I keep having the process get stuck, consuming epic amounts of memory and processor.


Also on the Mojave beta, but I was having the same issue on my other computer before I updated to the beta. It seemed to start when I tried to enable Dropbox sync. I have tried to disable its but I am not sure that I was successful as I had some settings "come back" that I had disabled.

Possibly click the "Delete cloud data" and "Reset Sync Status" again and make sure to uncheck the checkbox:

yeah, i did that, but like I said at some point some actins I'd deleted came back, so...

Well, I didn't click delete the data because I went ahead and deleted the folder from Dropbox after I had those settings re-appear.

BTT relaunches and is perfectly behaved, for a while, Then I find it's gone rogue again and I have to kill it.

That definitely sounds like a Drobox sync issue. Would be great if you could also send me the debug info, it should contain various logs about this. Possibly deleting the folder manually caused more confusion, thus I'd still try to press the delete cloud data button.

However I think your issue is different than the previously posted.

Would it cantina logs from several days ago? Because that's when the "shortcut came back" happened. After deleting the folder in Dropbox BTT and Dropbox unlinked (I got a notification about it). I'm not going to relink Dropbox to BTT at this point.

But the 90+GB of RAM was this morning, so I don't think that is sin related.

the logs from today should be fine! They will show whether BTT still thinks Dropbox sync is enabled (which may cause such weird behavior)

OK, searched the drive for log files and didn't find them. Searched the app for long files and didn't find them. Where do I get hem/generate them?

Oh, wait a minute. My version is severely out of date. I guess I assumed it updated on its own? In fact, it is older than when I paid for BTT on 9 Feb as the update I just downloaded was dated 2 Feb. I think the version I had was 2.438? I've updated and we'll see if this recurs.

Ah exporting the debug info works like this:

I'm having the same issue as well.

  • macOS Mojave 10.14.3
  • BTT version: 2.428

It goes away when I restart BTT, but after a while, I notice my MBP fan getting louder and louder until I notice it is taking up +95% CPU.
Will send debug log file when it happens again.

Updating seems to have solved the issue for me.

Looking at your logs I think you might have some faulty USB device connected to your computer that constantly disconnects&reconnects. Could you check that?