BTT use force changes the language to English

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
Whenever the BTT action takes place (any action on any application), the output language forcefully changes to English from other language. If the language is already English, nothing happens.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Pro

Device information:

  • Type of Mac: MacBook Pro 16-inch (2019)
  • macOS version: Monterey (12.2.1)
  • BetterTouchTool version: 3.742

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
I have other MacBook (MacBook Pro 15-inch, 2018) with different OS (Big Sur 11.6.4) and BTT (3.741) which does not cause such issue.

***New information. I found out that this problem happens only when the "caps lock" key was used to change the input language (this feature was added in OS 10.15 Catalina). I use "caps lock" to change Japanese and English, and the way it works is that the language will be English when "caps lock" is inactive (no glowing) or Japanese when active (glowing green). When it is active (glowing the green light), any BTT action thereafter will force change the language input to English. However, when it is inactive (no glow) and changed the language to Japanese without using "caps lock" there is no effect by any BTT action.