BTT unable to send shortcut to specific app when same as trigger.

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
BTT is failing to "Send Shortcut to Specific App", when that keyboard shortcut is the same as the triggering keyboard shortcut. The triggering shortcut still brings the target application to the front, but does not then send the action shortcut.

I'd like to do this because I have 2 applications that I spend most of my time in, and I'd like to be able to control Application B without having to leave Application A while being able to use the same keyboard shortcut in both.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Logitech G604

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

As an example: this configuration will not send the shortcut to the target application.

Device information:

  • Type of Mac: Mac Mini
  • macOS version: Mac OS Catalina : 10.15.6
  • BetterTouchTool version: 3.4.02

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

This is a blocker for us too! If it were resolved quickly we'd be sooo appreciative!

I am also getting this bug! We would greatly appreciate to see this issue resolved.

Yes, please fix this bug! Fixing this would totally help.

Seems to work fine here. In which app do you have it configured?

If you have selected "All Apps" as the container for this shortcut, then the shortcut will trigger itself by picking up the key command sent while Slack is in the foreground. You can also fix this by checking the "Prevent recursive triggers" option in the shortcut options pane.

For an alternative workaround, try creating a "conditional activation group" that only applies the shortcut when the target app (slack, in OPs example) isn't the active app. That way the shortcut sends as normal when not in slack, but won't self-trigger.

In the "send shortcut to app" action, unchecking the "bring app to front" option may cause the behavior to become more consistent in some cases.

I'm having the same problem here, but the trigger is specific to one app only. Tried "Prevent recursive triggers" option but didn't work. Here's what I'm trying to do. It simply freezes BTT before doing any of those 2 actions.