BTT stops working every couple minutes

After the BTT is started in a minute or two it shows nothing but two big empty buttons. It happens when I switch between windows.

Restarting helps, but again for a couple of minutes.

Affected device: touchbar

Device information:

  • Type of Mac: MBP 2020 Intel 13"
  • macOS version: 11.4
  • BetterTouchTool version: 3.562/3.564 alpha (tried both versions)

If I click "Show macos control strip" in settings, a "You have not configured actions in BetterTouchTool" message appears for a fraction of a second. Not sure if helpful but think this might help.

what does your configuration look like?

Not sure what exactly info is needed, but here's the screen.

most likely something is wrong with the shell scripts, could you post them here do I can have a look?

Or you can send an export of your preset to then I can check what’s wrong.

1 Like

Done, sent to the mail.
It worked fine in MacOS Catalina 10.something (last version available). Stopped working when I upgraded OS to 11.4

Ok, my bad, found the problem. I use shell scripts to run local php files. After OS update local web server stopped working returning not the script execution result but the script itself.

But thanks for the tip, it gave me a direction to investigate :slight_smile:

The thread can be closed now.