BTT stopped working when my license expired and I couldn't figure out why

BTT stopped working when my license expired and it took me multiple hours to figure out why

I've been using BTT for a couple of years. I'm super happy with it, and recommend it all the time.

Recently I migrated to take my MBP for service, so I migrated (using Apple's migration tool) to an old one. The migration tool works great, and most apps worked perfectly, except BTT. I tried lots of things to make it work again, but nothing helped. Finally, I deleted and re-downloaded it, and when I opened it, a message indicated that the license was expired. I bought a new license and it works again, but this made me loose a couple of hours.

Today, I got my MBP back, and first thing I noticed was that BTT wasn't working. I also reinstalled it, used my new license, and it works now, but I found the process a little frustrating.

Device information:

  • Type of Mac: MBP 15inch 2017
  • macOS version: 10.15.2
  • BetterTouchTool version: 3.207 -- I'm afraid I don't have access to the previous version

expired licenses don’t cause BTT to stop working, you can still use the last version you received during the license period. You just can’t use newer versions anymore.

Maybe you encountered some other issue? Most likely the catalina bug that requires to remove BTT from the accessibility list

Oh, I didn't know that. It must have been another issue.

I tried that fix, but didn't work. I'm using Catalina in both machines though.