BTT stopped and wouldn't start after update

Describe the bug

I restarted BTT upon seeing the notification that update 3.301 (1477) was installed. I noticed that it did not start back up.

I looked in Activity Monitor and only "BetterTouchProcessPrioWatcher" was running. I started, and this remained the only BetterTouchTool process running! I stopped the "BetterTouchProcessPrioWatcher" process and clicked the .app again, and all the usual processes started and immediately stopped! The only one left a second later was, again, "BetterTouchProcessPrioWatcher".

I restarted my computer and everything started again as usual.

Macbook Pro 2016 (2 usb-C, no touch bar). Catalina.

PS - I LOVE this software. Best money I've ever spent. It makes me want to start a blog.


could you try this build?

Do you have any other keyboard related apps installed?

Same issue, can confirm that build works.
I have karabiner-elements running.

Oh I also have Karabiner Elements running!

Great, thanks for confirming!

I have the same problem, but it is not fixed for me.

I downloaded the version you linked above, but it still won't run.

Before this, when it was still working, when I selected "update" from the BTT menu (Regular Channel), it gave me an error and was unable to update.

So I chose the Alpha channel thinking it might fix this bug, but then it started crashing and unable to start.

Can't get BTT to run, please help!

Well, I got BTT to run (the version you provided in this thread)...

What did I do?

I disconnected my MPB from my USB mouse, external monitor (thunderbolt cable), and power cable...

This has never happened before.


But, I still get this error when trying to update BTT using the regular channel:

I also experienced this issue after updating BTT (to 3.310, I think).

BTT 3.303 did not resolve the issue for me. I also completely removed BTT using AppCleaner and then tried running both 3.310 and 3.303 from a default state. They would not launch.

I do not have karabiner-elements.

I finally reverted to 3.328 3.298, which works.

That's weird, probably a different issue. It would be great if you could check whether there are any crashreports in the macOS console app (on the left select crash reports)

@oceansurf updating seems to work fine here, maybe some firewall issue or something like this? Are you checking for normal or for alpha updates?

I just sent you 5 crash reports in a private message. Let me know if you need additional information.

Above, I meant I reverted to 3.298. Corrected.

Thank you! Weird error, not sure why exactly it's happening but I'm catching it now and it should be fixed in 3.311!


I had a similar issue, after upgrading I could no longer launch better touch tools. I've had bettertouchtools since 2015 (on this mid 2015 MBP 15'). I believe it was due to an old version issue. When I deleted BBT with AppCleaner and downloaded the latest, it went into an infinite loop of asking me to update my Security and Privacy system settings to give BBT access to accessibility settings. When the pop stopped coming up, BBT was never able to launch again. What I had to do was go into Security & Privacy -> Accessibility, then hit the "-" to remove BBT from those settings. Then manually add the new BBT install that I moved into my applications folder and give it access.

This finally allowed me launch BBT again! wooho! Not sure what the programmatic fix would be for this though so an update can do this automatically for people upgrading.

unfortunately that one is a bug in macOS and as you already figured out - the only fix is to delete it from the Accessbility list (or run this terminal command: tccutil reset All com.hegenberg.BettrTouchTool). Only happens on few systems luckily.


I'm just checking for normal updates.

My internet connection / firewall hasn't changed. All my other services and websites etc work fine.

Is there a BTT log file I can check for this sort of thing?


Also, I just plugged back into my monitor (via thunderbolt) and plugged in my USB mouse and tried to launch BTT, but it wouldn't launch.

So I did a test and unplugged my USB mouse cable (left my monitor plugged in), tried to start BTT, and it started. Then I quit BTT, plugged my USB mouse back in, tried to launch BTT and it would not launch.

I guess I've narrowed it down a bit?
Hopefully this helps.

This should already be fixed in the latest alphas. In case auto update still doesn't work for you I'd recommend to download directly from

Ok, thanks @Andreas_Hegenberg, 3.312 fixed that issue, I updated via the Alpha channel and got it. BTT now starts (even with USB mouse plugged in).

I'm having the same issue, checking for regular updates gives an error, but Alpha update works. It's been like this for 2 days now I think.