BTT repeatedly starts and crashes on Mojave

Describe the bug
Since upgrading to Mojave a couple weeks ago. I haven't been able to use BTT. It would start, but then immediately pop up a window telling me to restart it. I would do that and it would have the same problem. Ended up having to kill it from terminal just to get the pop-up to go away.

I tried deleting the app and reinstalling. Now it will pop up a window saying I need a new license, which I think is true, since my license expired a while ago. But, before I can get the license, the window crashes, and then restarts automatically until I kill BTT from terminal.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Macbook Trackpad

The window closes too quickly for me to get a screenshot

Device information:

  • Type of Mac: MacBook Air (13-inch, Early 2015)
  • macOS version: 10.14.1
  • BetterTouchTool version: Just downloaded latest

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Dec 8 10:50:41 Skylers-Air[1] (com.wondershare.AnjoyTunesHelper[11971]): Service exited with abnormal code: 78
Dec 8 10:50:41 Skylers-Air[1] (com.wondershare.AnjoyTunesHelper): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.
Dec 8 10:50:50 Skylers-Air Wondershare TunesGo Helper[412]: [MobileGoHepler] checkNotificationSenderisitunes BetterTouchTool <NSRunningApplication: 0x225ca0 (com.hegenberg.BetterTouchTool - 11972)>

Also on Mojave, had repeated start and crash issue. I removed and re-added BTT under Security -> Privacy -> Accessibility preferences and the crashing stopped. Hopefully it works for you too.

For the record I had the same issue but without any windows -- just a a message in console:[29130]): Service exited due to SIGSEGV

Greg's solution to remove/re-add the accessibility permission also fixed the issue for me.

Yep this is a known bug in Mojave unfortunately.
(Mojave reports to BTT that it has Accessibility permissions, then BTT tries to use them. However in reality macOS has forgotten that BTT has these permissions and therefore BTT crashes. Deleting BTT from the Accessibility list fixes the macOS "memory").

Also see