Btt rendered In-app shortcut keys stopped working

Hi, first of all, thank you for developing such an amazing tool for us. I have been using your product since 2016 with BetterSnapTool.

Recently, I have started using BetterTouchTool and it is amazing. Yet, I found a bug that rendered some of my in-app shortcut keys or customised shortcut keys stopped working due to the potential crush or inactivation of the Option key - to be more specific, in-app customised shortcut keys (not universal shortcut keys) such as Cmd+Opt+Shift+S, Cmd+Opt+Shift+F are occasionally not working. I can fix the issue by clicking on its menu bar which shows the Shortcut keys and the option key will function again.

E.g., Im on the Affinity Designer App, I use Cmd+Opt+Shift+S to export the files in different file format. When this shortcut keys not working, the app will think that Im pressing only CMD+SHIFT+S which is Save as. Then I will click on the File Tab as below, let the system 'sees' the menu with Export... (CMD+OPT+SHIFT+S) on it, then the shortcut keys of export will function again.

I also tried fixing this bug by closing the BTT app and it will also resume normal. Appreciate if you could advise me what to do in order to fix this bug since I really like your app. Kind regards/ Jim

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Weird, I can't think of any reason why BTT would conflict with that.

In the BTT preferences, could you go to "Help => Export Diagnostic Debug Info in the menubar and send the result to me? (

Thank you, Andreas. I just sent them to your mailbox.

I solved this issue by deleting the customised hotkeys with using cmd, opt and shift at the same time

Thank you for your effort!