BTT Remote – Timeout

Hi,

just want to test the iOS companion BTT Remote, but i'm not able to connect?
BTT Remote discovered my mac, sharing is activated, but there is always a timeout.
Even with firewall disabled, there is no »signal«. Any ideas?

Thank you.

It's always a firewall or wifi-router issue :slight_smile:

Are you sure you allowed UDP and TCP for BTT in your Firewall?

Yes, i think so :slight_smile:
To be precise: i talked about the firewall embedded in the mac. Here BTT (and installed and signed applications in general) is allowed to receive connections.
Our simple fritzbox-router is not very rich on features and configuration options …

It's very hard to tell what's wrong in such cases.
Are you really sure that the macOS firewall was disabled for testing? (Just asking because it's really almost always caused by some firewall setting)

If you have had BTT installed for a very long time you may also try to open the macOS Keychain app and search for "BetterTouchToolRemote". If this finds a expired certificate, you can try deleting it from the keychain - sometimes it doesn't seem to refresh automatically.

Another run right now:

  • (Mac) Firewall (really) open
  • Router set to »allow clients to share/configure ports«
  • Dedicated port-forward for BTT with IP and Port (TCP & UDP)
  • Certificates still fine and fresh

I know that it's not BTT's fault :wink: But is there any option to monitor and retrieve the problem, for example in the console app?

Unfortunately not because in such cases BTT doesn't even know that a connection attempt was made ;-(
You'd need some special tools to monitor the network traffic.

In general no special settings on the router should be necessary as long as it's not specifically set to block some things.

Could you try a manual connection from BTT Remote using the IP and port displayed in the BTT Remote tab?

Yes, tried that first. Unfortunately it makes no difference.
An idea: Direct connection between mac and ipad via wlan-sharing?

I'm having the same problem.

I thought it was a version problem and I bought a lifetime license to be able to update to the latest version 3.373 (1597) on the Mojave OS and BTT Remote Control version 2.3.1 with BTT Remote PRO license

I've already made the following checklist:

  • Verify that my Mac's firewalls are disabled.
  • I removed "BetterTouchToolRemote" in the keychain app
  • I have already checked my router settings and tested them with a different router.
  • I tried to connect manually from BTT Remote using the IP and port shown in BTT Remote tab and it didn't work.
Imprint | Privacy Policy