BTT not disabling horizontal scrolling

I have just installed BTT. I've configured BTT with right-click red window button -> cmd-q (in Named Triggers section of All Apps) and it's working. I've made a couple of key sequence mappings which work. However, I have not been successful in disabling horizontal scrolling. The check-box is checked in the All Apps section but I can still scroll left-right in MS-Word with the surface of the Magic Mouse 2 on my MacBook Pro, running Mojave.

I'm running BTT 3.209 downloaded today (is that the alpha version?). I've rebooted. What can I try next to debug this? Horizontal scrolling is driving me nuts.

I've also tried
defaults write MouseHorizontalScroll -bool NO
which doesn't seem to work either.
defaults read MouseHorizontalScroll
reports 0 regardless of the setting of the BTT checkbox.

I've tried BTT with two different Magic Mice (both identical models). Same symptoms. However, when I load the Multitouch app (which also has a "Disable horizontal scrolling" checkbox), it does disable it. I am trying to avoid loading 3 different keyboard/touch/mouse watchers, not knowing how they might interact.

I've noticed that BTT does seem to disable horizontal scrolling initially, for a short while, but after some short time jostling the mouse around, it kind of gives up and after that horizontal scrolling is allowed.

Finally, even with the Multitouch app running and single-finger horizontal scrolling disabled, I notice that I can still scroll horizontally with two fingers. Is there any way of really disabling horizontal scrolling?