BTT: Keyboard Shortcut to launch BTT stops to work until BTT is restarted

Describe the bug

  • Setup Keyboard Shortcut for all apps: Left-Option + Left-Ctrl + C (like config) to launch BTT
  • Enter the above shortcut from time to time and at some point it stops working ...

It happens quite often and any other keyboard shortcut still keeps working and it also does not seem related to any specific app being in focus or something as far as I can tell.

I tried to find out why / when this happens, but it seems impossible to say!
Hence this bug request in the hope that I can somehow turn on debugging / logging in order to submit info here allowing to narrow down as to why the keyboard shortcut keeps stopping to work.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

  • Keyboard Shortcut

Screenshots
n/a

Device information:

  • Type of Mac: Macbook Pro 16"
  • macOS version: Calina 10.15.2 (19C57)
  • BetterTouchTool version: 3.219

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

  • If it's like this: I paid attention that BTT is NOT visible in dock (eg. as minimized windows).
  • When then using spotlight to try to launch BTT manually the BTT window also does not appear!
  • The way out of this is, that I found is to use the menu-bar icon of BTT to restart BTT
  • I just noticed that after I did restart BTT via the menu-icon I was able to bring up the configuration window, but the window did NOT allow me to access the MENU of the window (I tried to click on "Help" in order to see the BTT version, but the whole menu was dead). I did Cmd+Q quit BTT and then relaunch it, giving me again a fully functional BTT window.

So there are finally 3 symptoms of something being wrong/broken (not sure if they are separate issues or the same):

  • Keyboard Shortcut stops working
  • Launching BTT (via spotlight) does not show a BTT window
  • BTT window menu becomes unresponsive

I will now try to pay attention / test if they always appear all 3 at the same time!

Not sure if the issue should be renamed...

It just happened again (the keyboard shortcut not working) and I restarted BTT via the menu and then the menubar in the BTT window was working this time. I did not try to lauch BTT via spotlight though.

Also FYI: The menu within BTT being dysfunctional already happened at least one more time to me already in the past!

Imprint | Privacy Policy