BTT is running, but default touch bar still appears

Describe the bug
I installed BTT a couple of days ago. Briefly, I saw the vas3k touchbar that I installed. I worked through the settings and installed the location helper and json helper. Shortly after, the custom touchbar stopped appearing, and now I can't get BTT to display any touchbar at all. I have tried uninstalling and reinstalling without luck. I have also tried uninstalling the helpers. Other presets don't work either. I grabbed the logs from the About screen, but there wasn't anything interesting there. I tried resetting all settings from the advanced page, but still no luck.

Any help is appreciated!

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports)
  • macOS version: 10.13.3
  • BetterTouchTool version: 2.513 (850)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

it's probably just hidden. You can e.g. add a keyboard shortcut amd assign the predefined action "toggle BetterTouchTool Touchbar" to hide/show it.

Super. How do I unhide it when it isn't showing to begin with, so I only have the system's button set?

My system preferences meant that I wasn't seeing the BTT icon in the control strip until I went to Keyboard preferences and chose "Touch Bar Shows > App Controls with Control Strip." Previously it was just showing app controls, and there was no way to get back to BTT. Thanks for the help!

1 Like