BTT installation fails: BTT keeps me asking "BTT would like to access data from other apps"

Hi folks,

I was pretty happy with BTT within the last 2 years.
For some reasons I deinstalled BTT a few weeks ago.

Today I tried to reinstall BTT on my Mac M1 (meanwhile updated to Sonomia 14.0) but it
keeps me asking "BTT would like to access data from other apps".

Whatever button I press - this Question pops up again and again.
(additional note: my Mac is managed by my company - there are some security policies installed, maybe they interfere with BTT)

Anyone who can help me?

Kind regards


unfortunately that’s a known bug in macOS sonoma. You can workaround it by giving BTT „full disk access“ permissions in System Settings -> Security & Privacy -

Thanks Andreas - that solved the original problem.

Unfortunately another issue came up:

The BTT-icon does not appear constantly/stable in the top right corner icon list.
Most of the time the BTT-icon is hidden and whenever it comes up, it steals my mouse focus,
what makes typing this text here a real challenge.

In addition, I can not open the BTT-Window - it shows up a few seconds
and than disappears.

Any help is highly appreciated ...

Kind regards


Interesting: just realized, that the toggling BTT-icon problem disappears when I plug off my docking station.

When using my Mac without my 2 external monitors - BTT-icon appears stable in the right top icon line.
In addition, I can open BTT configuration window without any problems.

That's fine, but that's not my normal setting - normally I work in front of 2 external monitors,
using my macbook pro monitor as the 3rd monitor.

Is there any chance, to get that setting working with BTT again (about 3-6 month
ago everything was working fine)?

Kind regards


Ha - solved the problem myself:

I simply deleted or disabled everything regarding "Notch/Action Menu Bar":

First, I deleted all default items and alle user defined items in "Groups & Top Level Triggers" in the Notch Bar Setting (at that time I realized the "deprecated" hint ...)

In addition, I removed all checks in the "Notch/Action Menu Bar" in BetterTouchTool Setting, leaving it completely disabled.

That solved the problem - gosh!

Kind regards


1 Like