BTT has stopped appearing in the touchbar

Describe the bug
When BTT is running, the buttons I have assigned to the Touch Bar do not appear on the Touch Bar.
I have tried removing all my settings, tried a reboot, don't seem to be able to get anything to work?
The Touch Bar is showing the default settings for each app instead.
This is only since upgrading to v3.100

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touch Bar on Macbook Pro 15 inch 2018 running macOS 10.14.5

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Macbook Pro 15 inch 2018 r
  • macOS version: macOS 10.14.5
  • BetterTouchTool version: v3.100

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Can you check the settings of BTT if maybe this checkbox is selected. If so, uncheck.

Also, in BTT > Configuration > TouchBar Settings > Enable Touchbar Support, uncheck this if it's checked. Then restart BTT, check that again, restart BTT again.

Now it should work.
If that is the case you could be affected by this BUG:

Otherwise... lets wait for the Pros

It could also just be hidden. In general I always recommend to setup a keyboard shortcut and assign the predefined action "Toggle BetterTouchTool TOuch Bar", that allows you to easily show/hide the BTT bar at any time.

Many thanks for both these suggestions. I have tried them both, but I still cannot see any buttons in my Touch Bar. Below are screenshots from the app, from my System Prefs, and a photo of the touch bar whilst the config screen is open. It was all working well until I upgraded BTT recently!


BTT touchbar shortcuts:

Looks good to me.
Maybe go to Help => Export Diagnostic Debug Information and send the resulting BetterTouchToolDebug folder that will be created on your desktop to, then I'll try to reproduce it with your exact settings.

Your debug export also seems to work here (after toggling it visible once). :-/
Maybe try to enable "show control strip" in system preferences => keyboard, I usually keep that on, so not sure wheter that could have some side effects.