BTT crashes at launch because of invalid Shortcuts setting

Describe the bug
A clear and concise description of what the bug is.

Hello! My BTT is repeatedly crashing on launch. I believe I broke it by accidentally selecting to use a MacOS Shortcut for a trigger action, but I'm still running an older version of MacOS that doesn't support Shortcuts. Whoops. :man_facepalming:

Could you help me fix my profile?

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

I accidentally selected the Shortcut trigger action when trying out the new StreamDeck support. (which is sweet btw!!)

Device information:

  • Type of Mac: Macbook Pro 16, 2019
  • macOS version: Catalina 10.15.7
  • BetterTouchTool version: (please post the exact version - not just "the latest one") - 3.816 build 1960

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

I'm a programmer myself, so I tried to troubleshoot by opening up the btt_data_store SQLite database, but I wasn't able to determine what I might need to change to unset my incorrect trigger config. All that to say, that I'm game for a more nerdy solution to fix my BTT profile in order to get back up and running. :nerd_face:

Thanks for making such an awesome app. BTT is essential software for me on every Mac I use.

could you send me the crash log? Should be located in your macOS (I think the section was called "User Reports" on 10.15

Wow! You are extremely responsive. Here's the most recent crash log. Thanks! (29.4 KB)

I think this crash should be fixed in 3.821: (

That worked! I'm back up and running. Thank you SO much!

I've got the same issue, BTT crashes when I launch it after trying to configure Stream Deck settings. Can't seem to launch it, even in the version you provided in a previous response. Hope you can help me out! Here's my text crash log: (30.1 KB)


I played with stream deck support, did something to configuration, and now cannot access config screen anymore because application quits. I attach a log.

(upload:// (7.0 KB) (7.0 KB)

Sorry I did not manage to attach properly the log last time (or so I think)

I described the issue incorrectly. BTT launches and works, but as soon as I try to enter configuration screen then it crashes. Also, the crash occurred when I was playing with setting an icon for the deck.