BTT crashes after using a three fingers swipe on touch bar

Describe the bug
The application crashes sometimes when I'm using three fingers swipes with the touch bar.
Works well with 2 fingers swipes.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touch Bar

The three fingers swipes are mapped to brightness control

Device information:

  • Type of Mac: MacBook Pro (15-inch, 2017)
  • macOS version: Mac OS X 10.15.5 (19F101) / Catalina
  • BetterTouchTool version: 3.390 (1613)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
An external monitor and a MIDI keyboard (MPK Mini Mk II) are connected to the laptop.

OSX Crash reports (2 examples): (56.1 KB)

This happens every single time to me too. It's really frustrating.


Happens to me too. Bump.

1 Like

Unfortunately I think this can only be fixed by Apple. It only seems to affect some Macbook models.

You can try to enable the "Global" option for the gesture, then BTT will use a custom way to recognize the gestures, which however might not be as responsive.

I'm unfortunately seeing the same bug but only started appearing in 10.15.5, worked perfectly fine before then. Is the issue with specific models you describe just with this new update or has it been around longer?

Can confirm this bug. Happens with other configurations such as two and four finger. Quite unfortunate that these gestures don't work :frowning:

1 Like

Possibly try the latest alpha I uploaded earlier today. It doesn't fix the bug itself (only Apple can), but hopefully BTT won't crash anymore.

1 Like

I can confirm this bug too, with 2, 3 and 4 fingers swipe. Latest alpha version available in alpha channel is 3.358, April 16 2020 :slightly_frowning_face:

1 Like

I have this bug as well for 2 and 3 finger swipe, Only started happening after 10.15.5, currently running BTT 3.389.

I have the same problem. It was one of my favourite features of Golden Chaos too :frowning:

I know that the bug is on Apple's side @Andreas_Hegenberg, but do you think there might be a workaround ?
Can we help you figure something out through alphas ?

If I check "Global" in the action, most of the time when I swipe, the action isn't triggered.
If I uncheck "Global" in the action, most of the time when I swipe, the the Touch Bar freezes and is unusable afterwards.

Could you try the latest alpha version of BTT?

Following your comment I updated from 3.392 to 3.393
I'll let you know if it's any better.
Let me know if I can be of some help for anything.

Same behaviothing still happens with 3.393 @Andreas_Hegenberg

Does anyone know if the issue still occurs on Big Sur?

I haven't tried, but I'm interested by the result if you did :slight_smile:

For your information @Oliver_Cooper, @Andreas_Hegenberg, Big Sur seems to have fixed the issue for me.

BTT : 3.505 (1643)
OS : macOS Big Sur 11.0.1 (20B50)
Mac : MacBook Pro (15 inches, 2016 - 2,7 GHz Intel Core i7)

Big Sur 11.6 again problems with crashing after using swipe gestures