BTT Crash When Selecting New Configuration UI - Catalina

Crash Report: BetterTouchTool_2019-10-18-204151_Kevins-MacBook-Pro-2.crash (100.4 KB) BetterTouchTool_2019-10-18-204151_Kevins-MacBook-Pro-2.crash

Describe the bug
BTT crash when selecting the new configuration UI after Catalina update (does not crash when selecting old configuration UI)

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Input défice not applicable, BTT seems to operate OK unless the new configuration UI is selected.


Device information:

  • Type of Mac: MacBook Pro (15-inch, 2018)
  • macOS version: 10.15 (19A602)
  • BetterTouchTool version: 3.206 (1382)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Issue began immediately on catalina upgrade.

Troubleshooting Performed:

  • Deleted BTT from accessibility numerous times
  • ran tccutil reset Accessibility numerous times
  • Uninstalled/reinstalled numerous times
  • Turned off Dropbox syncing
  • Removed ~/Library/Application Support/BetterTouchTool numerous times

After many hours of trying to solve this, it appears as if the issue is related to a combination of presets that previously worked in 10.14 that now cause the crash. During troubleshooting, I was unable to launch the new UI so I begun dismantling all my triggers/gestures/presets one by one to figure out what was the issue and eventually was able to launch the new UI as of last night once I was down to 1 preset with about 1/4 of the triggers I had previously. But this morning, after trying to rebuild my master preset by adding some tigger/button/gesture/group, the crash began to occur again. I made several backups throughout this process and have restored back to every one hoping the crash would cease with one of them, but the issue is continuing to occur.
I believe I have tried everything I can think of so now I am reporting it.

I have this same issue - is there a fix or a workaround please ?

I have the same issue. Great job by @kevin-funderburg describing the bug.
Is a downgrade recommended?

1 Like

Unfortunately this crash is a bug in Catalina related to the rendering of specific strings. I have already been contacted by various other devs that found these reports here because they encountered the same issue.

Apparently resetting all the UI state can help in some cases, however this would also delete your BTT settings (not the configured triggers though, they will still be available afterwards):

1.) Quit BTT
2.) Run this terminal command: defaults delete com.hegenberg.BetterTouchTool

Possibly try upgrading to version 3.209 - it was built with a newer version of XCode which may already have a fix for this issue, but unfortunately I can not reproduce it here so I can't tell for sure.

Thanks for the fast reply!
v3.209 solves the issue for me.
v3.206 (via Setapp) crashes when I launch the new Configuration UI, plus another issue now where the menu bar icon goes away, then comes back in a cycle.

Setapp doesn't seem to know about 3.209 yet, so for now I'm running a downloaded version from here:

1 Like

v3.209 solves the issue for me too. I previously tried 3.219 and 3.220.

1 Like

Hi - I want to let you know that your SetApp users need an update!

SetApp is still providing v3.206 - which is broken on Catalina. If you try to select "Configuration", it crashes.

I had good luck with 3.209, and just updated to 3.332. So I'm working around this, but I think you should get the SetApp version updated - a lot of users are probably assuming the SW is poorly designed. And we know that is not the case :slight_smile:

Luckily it crashes only in a very specific situation due to a Catalina bug. It should not affect many users. However the Setapp version will soon be updated - currently doing the final testing for the stable rollout of 3.333.