BTT constantly crashing

I am using BetterTouchTool >= 3.952 (November, 25, 2022)

I'm on a 13" 2020 2 Thunderbolt 3 ports MacBook Pro and Ventura 13.0.1.

BTT will not stay open. I've tried restarting multiple times, updating, everything. This is so annoying. I am also using the Golden Chaos 3.563 preset for touchbar, but BTT won't even stay open long enough for me to disable it. The touchbar is constantly changing around and messing with what I'm doing, as it seems like BTT tries to reopen but fails. Or something. I have no idea, but it's so frustrating and has taken up my entire morning.

Please provide any crash reports you can find in the macOS console app under "Crash Reports".

To enter safe mode in BTT, use this terminal command:
defaults write com.hegenberg.BetterTouchTool BTTSafeModeEnabled YES && open -b com.hegenberg.BetterTouchTool

Nonstop crash reports the entire time I've been using my laptop since the 10th.
crash reports.zip (111.2 KB)

There seems to be an issue with one or multiple specific album covers that apparently crash the now playing widget in golden chaos.
This has been reported before, but I haven't been able to reproduce this yet.

If you can find what album cover causes the crash please let me know.

So far the only reports I got for this, was from users who used the iTunes Match functionality to upload their music library to the cloud.

I don't know if it's a specific album cover. I have played 2 albums today, one from Apple Music streaming and one from MP3s I downloaded. It could be a too-large file size for the album cover? This is an mp3 from what I'm listening to now. I tried putting BTT into safe mode but it was still freaking out. Is there a way I can uninstall and re-install BTT without goldenchaos?
07 Remember Me As A Time Of Day (Remastered).mp3.zip (11.7 MB)

Also thank you so much for getting back to me so quickly. I really do appreciate it.

Also, yes I use iTunes Match.

Nice! Your mp3 triggers the crash immediately and I'm able to see what's wrong. I'll upload a fixed alpha in a few minutes.

1 Like

I hope this was the only place where this code was used, but for now it seems to be fixed with this version: btt3.9993-2193.zip (folivora.ai)

Thanks a lot, I have been hunting this issue for ages.

Thnks for doing this so quickly. How do I delete nd uninstll the previous version? lso, my (@- eyy) key doesn't work now...?

You just need to replace the old one with the new one. No need to uninstall.

If you want to get rid of everything, delete this folder:
~/Library/Application Support/BetterTouchTool (got there via Finder => Go => Go To Folder, make sure to include the ~)

Hey I know you did so much to help, and I appreciate it. I got my "a" key working again by completely deleting the folder you mentioned and re-installing BTT.

At this point, BTT window snapping works for me (yay!) but none of the trackpad gestures work anymore. (I had to re-enter them.) The Touchbar modications no longer work either. Is there some new permission in Ventura I need to re-enable? I'm fairly sure I set up some gestures just how they were before (eg, three-finger-swipe left/right to switch between tabs with CMD+SHIFT+])

I don't think there have been any changes. Could you post a screenshot of your gesture config?

I might have completely forgotten how to do this correctly... Here's a screenshot

this looks fine! If window snapping is working, BTT also has all necessary permissions.

You can go to Help-> Export Diagnostic Debug Information, and send the result to andreas@folivora.ai, then I'll be able to tell what's wrong.

Oh man I'm sorry - I forgot to tell you that safe mode needs to be deactivated again after you had it active once.

This terminal command while BTT is quit will do the trick. I'll now add a warning to BTT when safe mode is active.
defaults write com.hegenberg.BetterTouchTool BTTSafeModeEnabled NO