BTT and Terminal help

Hey guys, I'm trying to configure a BTT macro that opens up Terminal, pastes the Terminal command and pastes the link of a YouTube video from the clipboard. For some reason Terminal doesn't recognize the "Enter" keystroke and the entire macros fails. Here are all the steps in the macro:

Launch Terminal app
Delay next action by 0.01 seconds
Paste Terminal command to download the video (Paste Custom Text)
Delay next action by 1 second
Paste Items: 2 (with format) = (pastes the YouTube link from Clipboard Manager)

I've tried adding a Delay before Enter, I've also tried using "Send Shortcut to App" but both of these things didn't work. Speaking of the Delays, I discovered through trial and error that the delays were essential in making sure the text commands pasted in correctly, though I have no idea why that is exactly.

Essentially the only "step" that isn't working is "Enter". Hoping somebody here could point out what exactly I'm doing wrong and what I can do to make this macro work. TIA!