Blocking my whole computer

With a again and again upcoming window saying: Need to restart BTT

BTT Version 3.144
Mac Os 10.14.5

can't use the payed software anymore .. very sad!!

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Could you provide a screenshot or the complete wording of the message you are seeing?

Probably some sort of file permission error on your file system. You can delete this folder to reset BTT:
~/Library/Application Support/BetterTouchTool (open ~/Library/Application Support/ via Finder => Go => Go to Folder) - make sure to export your currently used preset if you want to keep your settings.

Do you have enabled BTT in System Preferences => Security & Privacy => Privacy => Accessibility? If so, try to delete it from there using the - button, then add it again.

will try to reset!
(can't export any presets because i can't do anything if i open BTT :wink:

thx for your quick response!

picture upload needs approval ?!

.. tell you if m

You can also create a backup of the ~/Library/Application Support/BetterTouchTool folder, that would also allow you to restore your settings later.

Hi Andreas,

I deleted the whole folder (moved it onto my desktop) .. now BTT starts - appears in the menu bar .. but disappeares after 2 seconds and is obviously off again.

I checked firewall beforehand .. will try to switch it off and on again!

This sounds a lot like this Mojave bug:

no .. it is working in the back .. it is coming an going and is writing new infos into app-support after deleting

will try the terminal command.

but have to restart my lap

will get back to you after I tried it!

Hi Andreas

thx a lot .. switching Privacy Accessibility off - on did work!!

everything fine again!

ciao .. and thanks for your fast help! it made my day

1 Like