BetteSnapTool not working with second monitor

Hi,

I'm using a Mac Mini and Catalina 10.15.1. I've added a second monitor using an HDMI cable but when I switch on the second monitor BetterSnaptool stoops working.

How can I fix, please?

Many thanks,

John

in general BST works for with as many monitors as you want. However custom snap areas are always bound to a specific monitor, so if you are using these you will need to create a separate setup for your external monitor

Thank you, Andreas. I'm not using custom snap areas, in fact, I've left a the settings alone. BST stops working completely when I plug in the second monitor.

Strange, I haven't heard of such an issue before. Is it a normal monitor, connected directly via HDMI? No USB graphics or something like that?

Possibly just try to restart your system, maybe something is in a weird state. Also make sure BetterSnapTool has the necessary permissions in System Preferences => Security & Privacy => Privacy => Accessibility and possibly Screen Recording (https://folivora.ai/blog/post/13011). Also make sure to use BetterSnapTool 1.9.2 (available via the Mac App Store)

Thanks again. I've checked all of those points and they were all OK. I've disconnected the monitor for now and I'll do some research and try again tomorrow.

I've tried it again tonight and it seems to be working now. Many thanks for your help.

Hi, looks like you could probably help me with another issue, I got with a second monitor.

I created some snap areas with that monitor and suddenly they are gone. Probably BST does not recognize the monitor as being the one, I saved the snap areas for. BST just treats the monitor like a new one. I don't want to start all over again with setting up the snap areas and of course I do not want to take the risk, that this might happen again. Do you know, if there is a way to somehow "restore" the snap areas, which already exist and "assign" them to the monitor?

Thanks in advance!
Kind regards
David

Sorry, David, I cannot help. My issue sorted itself out. It just started working the following day.

Kind regards,
John

Thank you!

@Andreas_Hegenberg maybe you've got help here? Looks like you might have the expertise :slight_smile:

Did you maybe change the resolution or positioning of the screen?

Thank you for your answer!

The resolution has not been changed

Maybe the positioning. Could this have an effect on the snap areas?

What I did change with certainty is the frequency. Setting it back, does not have any positive effect.

Also I did change the USB-C adapter. I tried the old one again, without any positive effect either.

do any of these changes have an effect to the snap areas in particular?