BetterTouchTool Quit unexpectedly - out of no where BTT is just not working anymore.

Describe the bug
This came out of no where. I did not update macos nor did I update BBT. During boot, I just get a message that "BetterTouchTool quit unexpectedly."

Keep in mind, this was working since I got BTT, around 2017, with no issues whatsoever.

Things I tried:

  • Downloading different versions and trying to start - nothing
  • Acceessibility removing/readd - nothing
  • Trying different users, including guest - nothing.
  • Force quitting BTT instances.

The log is attached, please suggest any fixes. Your help is much appreciated.

Device information:

  • Type of Mac: Macbook Pro 2015 retina (Dell-Hackintosh)
  • macOS version: 10.13.6
  • BetterTouchTool version: (2.536), The one that is always working but stopped working suddenly is 2.428

BetterTouchTool_2020-02-10-032550_MacBook-Pro-3.crash (68.8 KB)

Looks like some file system issue. Did you recently change your macOS username or something like this? Or did you encounter any hard drive issues?

Apparently this folder doesn't exist anymore or something like that:
~/Library/Application Support/BetterTouchTool (~is your user directory). The Library folder is hidden by default, in order to open it you need to use Finder => Go => Go to Folder => Enter ~/Library

Thanks for your answer.
No user name changes or Macos related changes at all. But I am looking into some possible file pathway changes.

The file under Application Support exists as: com.hegenberg.BetterTouchTool

I am thinking it maybe a read/write issue, where app files are not found; a complete removal and fresh install might be a solution?

Thanks again for your help, Andreas.

There shouldn't be a com.hegenberg.BetterTouchTool file in Application Support - that belongs under ~/Library/Preferences/com.hegenberg.BetterTouchTool.plist

Could you post the output of this terminal command?
ls ~/Library/Application\ Support/BetterTouchTool

~/Library/Application Support/BetterTouchTool: No such file or directory

Very weird :slight_smile:
That folder shouldn't just vanish.

Can you think of anything that might have deleted it? Does the rest of your application support folder look alright? (ls ~/Library/Application\ Support/

Vanish!! I know right?!

Directory looks fine with the rest of the programs. I've done a few configs with system files backups - but nothing too crazy to start deleting files. It seems only BTT is having issues, if they are related, which I doubt.

No sure where to go from here, downloading again? but I tried different version, something might be preventing file creation at Application Support?

Really weird I haven't encountered this before :slight_smile:
Usually BTT tries to create that folder again if it is removed, but possibly it can't due to a file permission error.

Could you try if / what error you get when you try this terminal command?

mkdir ~/Library/Application\ Support/BetterTouchTool

mkdir: ~/Library/Application Support: No such file or directory

Huh, but ls ~/Library/Application\ Support/works?!

That error sounds like your whole Application Support folder in your user directory is missing.

Yea seems like parent directory is off.. yet it shows working fine; listed everything under Application Support.

Ok, let me see whats going on and get back to you

which ~
output the correct path? (it will say something not found, but is something correct?)

Does ls ~ work? Maybe the auto expansion of the tilde is somehow broken?

is definitely working,

which ~
dosen't seem to be working.

Ok obviously this is not a BTT issue, but BTT is fallen victim. I think some of my directory setups/permissions are not alined.. I am diagnosing now.

Ok let me know if you find anything, I have no idea what could be the issue !
Just to be clear which ~ is not supposed to work, I just used it to quickly output the path of the home folder (there are probably better commands for that). In my case it returns "/Users/andreas not found "

My BTT is in a crashloop and I have changed username in the past. ApplicationSupport folder and prefferences plist files(2) exist in my folder structure.

For now I get the Unexpected Error, hit ok/cancel and then reopens.
Any suggestions?

try to download a fresh copy of BTT from

Unexpected error usually means the app binary is somehow broken

I had tried it in the past as well. I just did it again. still the same error.