BetterTouchTool freezing up MacBook Pro on lockscreen

No luck on that front, I'm afraid - this Catalina install is a fresh one. I actually reformatted my laptop because I thought the upgrade had borked something and was causing issues with the lockscreen.

So if you're seeing some loop in the sample then it's a bug with Catalina, and not something I brought over with the upgrade from Mojave since this is a completely fresh installation with no Mojave traces.

Thanks for taking the time to look at the samples :smiley:

Just signed up to say, despite not being a BTT user (although I know it's cool) I have similar problems on my Catalina MBP,

xpcproxy[297]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port

I see the above message constantly.

I have a lot on the machine as it's a dev box, but running 10.15.1 didn't solve it.

Really annoying.

Also I notice crazy battery drops during sleep. I really want to know what the XPC issue is.

Also signed up to just say that i have this issue too. loginwindow chews CPU on sleep and is unable to wake. I have to SSH to kill loginwindow all the time causing a whole lot of other inconveniences on keychain access. Disabling BetterTouchTool solves the issue.

it will be great to get a fix. Thanks.

My machine seems to experience similar issue with interaction between BTT and Trackpad Handwriting. BTT ver. 3.206 (1382). Macbook Air Retina 2018

Syslog at time of login window freeze reports the following:

Nov 13 15:11:42 itachi syslogd[107]: ASL Sender Statistics
Nov 13 15:11:43 itachi xpcproxy[36922]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port
Nov 13 15:11:43 itachi xpcproxy[36923]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port
Nov 13 15:11:43 itachi xpcproxy[36924]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port
Nov 13 15:11:43 itachi xpcproxy[36925]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port
Nov 13 15:11:43 itachi xpcproxy[36926]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port
Nov 13 15:11:45 itachi logd[125]: Power button HID event - flushing proactively
Nov 13 15:11:51 itachi xpcproxy[36934]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port

*Update: After disabling trackpad handwriting issue has not reappeared since. It's been four days.

hey. signed up with a similar problem, also BTT and catalina

but: i have never used/enabled/disabled any handwriting tools! also, handwriting tools are not enabled, i checked.

it's a completely fresh install of catalina, hardly anything installed.

unfortunately, i am not sure what caused the issue exactly. i was setting up the touch bar, when the colored spinning wheel appeared, the system went more and more unresponsive, i could still move the mouse, but no access to any system functions, no checking or killing of processes possible. the fans sped up, the macbook was going very hot, so i decided to instantly shut it down. i looked at logs via console and found similar entries to the ones posted above.
it -may- have been caused by two things. either by connecting an external usb keyboard, or by putting the display to sleep, or by none of these actions. i cannot recall anymore.

in the logs, i noticed attempts to update the system or at least attempts to check for updates at the time of the crash.

this issue doesn't seem to be necessarily related to the handwriting tool. it seems its related to BTT on catalina, however.

are there any news?

thanks a lot

This sounds like a very different issue:-) why do you think BTT was related to your freeze?

because i was using the system for days without any problem and just after installing BTT and using it, this happened. also, when googling the system logs, it led me to this forum, where i found very similar (partly the exact same) log text lines
you say, it sounds like a very different issue - why? do you already have an assumption?

sorry for asking again, but your help would mean quite a lot. why do you think it sounds like a very different issue?

any chance of giving further support here? dead end?

Hi! I've also experienced issues with forcing the computer into sleep via BTT (touch bar button). I am running Catalina. When I lock using the touch bar button, my computer ends up restarting while sleeping (within 1-2 hours of sleep mode).

I installed the trial version of BTT in August (MacBook Pro 16-inch, 2019) and started experiencing the issue of the computer hanging completely on the lock screen when waking from sleep a little over 2 weeks ago coincidentally right after I paid for a lifetime license).

It happens about 50% of the time when I wake the machine. The screen is either stuck on the lock screen prompt (nothing is clickable on the lock screen), or it displays a black screen. There is sometimes a spinning wheel. Sometimes, I have to force it to reboot. One time, it rebooted on its own after hanging/freezing for a while. Lately, I've taken to closing and reopening the lid several times to avoid the reboot process. This has worked, but is obviously not ideal and not something I want to keep doing.

I also have a MacBook Pro 15-inch, 2016, which has never had any issues waking. I installed BTT on it just yesterday and experienced this issue the first time I tried to wake from sleep after the BTT install.

Both machines are running macOS Catalina 10.15.6.

I deleted BTT from my 16-inch machine today and haven't had any issues waking since then. I love BTT, but am almost at the point of requesting a refund for the license (since I paid for it only a little over 2 weeks ago). Really hoping for a solution...

I am a long-time fan, but since the last "major" release (3.4?) I get all kinds of crashes, weird lockups, the computer locks itself while I am using it, crashes during sleep, etc -- but, with BTT disabled, none of those things happen.

I'm running Catalina 10.15.6, EFI up to date, SIP is on, XProtect/Gatekeeper/MRT/TCC/kexts all up to date. I run a MacBook Pro with Touch Bar, 15", "MacBookPro13,3"

I'd love to know if there's a way to get back to stabletown, please!

Following up: Updating to Catalina 10.15.7 appears to have addressed the issue. I haven't had the freeze/hang on wake since updating on both of my MBPs running BTT.