BetterTouchTool freezing up MacBook Pro on lockscreen

It's in BTT config, under Advanced Settings -> Scripting BTT -> User Script Variables

Alright, making an executable shell script for that so that I can run it when I SSH in...

My variables are like so:

dateSize: small
showZeplinBadge: false
showOptionMenu: true
showFantasticalBadge: false
showVolumeMute: false
menuBarSize: large
showCollapseMenuBar: false
showChromeCanaryBadge: false
showTumblrBadge: false
showFirefoxBadge: false
showMapsBadge: true
dateFormatSmall24Hour: H:mm
showRefresh: true
showSettings: true
showMailplaneBadge: false
showCurrentLanguage: false
dateFormatMedium: MMM d h:mm a
showDiscordBadge: false
showWeather: never
showWhatsAppBadge: false
showVolumeDown: true
showEmojiPicker: true
showThings: false
showSkypeBusinessBadge: false
showConnectAirPods: false
showAbstractBadge: false
dateFormatLarge24Hour: E d MMM H:mm
timeFormat: 12Hour
showConnectBeats: false
showNowPlaying: dynamic
showiMessageBadge: true
showTwitchBadge: false
customVariable1: controlMenuOn
showShowFinder: full
showTelegramBadge: false
showVolumeUp: true
dateFormatLarge: E MMM d h:mm a
showSkypeBadge: false
showRemindersBadge: true
showOmniFocusBadge: false
showNewTab: true
showBrowserTabs: true
showNewsBadge: true
showClipboardHistory: false
dateFormatSmall: h:mm a
showFacebookBadge: false
customVariable3: commandMenuOn
show1Password: false
showWifi: false
showSiri: never
showChattyBadge: false
showCarrotBadge: false
useNormalEscKey: true
showReminders: true
showSpotlight: never
showBatteryPercentage: false
showAppleCalendarBadge: true
showBoxyBadge: false
showBrightnessUp: false
showHazeOver: false
showColorSnapper: false
showDayOne: false
showAirmailBadge: false
showQQBadge: false
showSafariPreviewBadge: false
showSparkBadge: false
showBrightnessDown: false
showPolymailBadge: false
enableWindowSnapper: true
showConnectGamepad: false
showSuperhumanBadge: false
showYakYakBadge: false
showDiscordCanaryBadge: false
showNotificationCenter: never
showBluetooth: false
showWindowSnapper: false
showCalendar: true
showThingsBadge: false
showConnectBose: false
showBattery: never
showMailMateBadge: false
showSafariBadge: true
showGoofyBadge: false
showBackForward: true
showPostboxBadge: false
showDock: false
showTrelloBadge: false
showMaipoBadge: false
showMediaControls: dynamic
showCaffeinate: false
customVariable2: optionMenuOn
showOutlookBadge: false
showCalculator: false
showFranzBadge: false
showCaprineBadge: false
gc_version: 3.202
showBodoBadge: false
showShowPaste: false
showSlackBadge: false
showWindowSnapping: true
showChromeBadge: false
showDeliveriesBadge: false
showAppleMailBadge: true
showCommandMenu: true
calendarApp: calendar
showFaceTimeBadge: true
dateFormatMedium24Hour: d MMM H:mm
showControlMenu: true
showMicrophoneMute: true
showTweetbotBadge: false
showTwitterBadge: false
showAirDrop: full
showWeChatBadge: false

I forgot to mention, I manually edited the preset in BTT because GoldenChaos currently does not have the option to hide the clock (and I don't need a second clock on the touch bar), so I just clicked on hide widget inside the BTT settings. Shouldn't be an issue though, since this worked 100% on Mojave.

@Andreas_Hegenberg not a freeze, but my MBP is now screaming again with distnoted and BTT taking up most of the CPU cycles. I ran samples on the distnoted process as well, in case it helps.

(oh and the uploader prohibits text files so zip it is) (491.0 KB)

Interesting. I think it seems to be stuck deep inside some system function that does something with handwriting support for the trackpad.
Is your system set to a language that uses handwriting via the trackpad?

In general it seems to somehow be related to the input language. Does GoldenChaos has something that displays the input type / language?

That explains it! One of the runaway processes was TextInputMenuAgent. I do have Chinese handwriting support enabled. I take Chinese classes (against my will) and whenever I need to input Chinese characters I just draw them using trackpad input because I don't know the pinyin equivalent. (Yes I still suck at Chinese, haha)

Should I try and remove those language input methods? I'm not sure if GC has input language whatever applets/widgets.

Edit: Looking at the variables I see this: showCurrentLanguage: false. Maybe that's the language switcher option? My Mac is not near me at the moment..

And here's the interesting part...

I have handwriting support enabled too! :grimacing: but it is not activated. (I have seen TextInputMenuAgent going haywire once too!)

I will try to reproduce this. I'm not yet sure whether this is a Catalina bug or something else. (The freeze happens in a system framework that doesn't seem to be triggered by BTT, but it is still somehow affected by the BTT process).

I think it could be some Apple Script in GoldenChaos which accesses the input type stuff and by doing this triggers a bug in Catalina, but I'm not sure yet.
If you don't need them, try to remove these input methods until I have more information.

Thanks for the confirmation @Andreas_Hegenberg! I will remove the input methods until this is fixed. For reference, here is my configuration. The only thing that is different from @cheemeng is the Simplified Handwriting input, while @cheemeng has Traditional.

Again this is some "what are the odds" situation, haha, I never expected someone else with the same MBP configuration and the same language layout! Thanks @cheemeng and thank you @Andreas_Hegenberg for looking so closely into this bug report!

I just noticed something weird while removing Handwriting support.

In the System Preferences input window there was no Handwriting method listed.

To fix this I had to go inside the Terminal and force-quit TextInputMenuAgent a bunch of times until it finally showed under the Input Sources menu. However, clicking on the '--' minus button to remove the method didn't reflect changes inside the Input Sources menu, but the Handwriting method disappeared from the menu bar:


After relaunching TextInputMenuAgent and System Preferences both of them now display the correct settings with no Chinese input. Really fascinating. I wonder if this is some Catalina bug that is yet to be fixed.

I then launched BTT, unsurprisingly the CPU shot up once again to 100%, distnoted being the culprit. I force quit distnoted and now my Mac is running really well. Still wondering how the heck the Input Source bug manages to trip up the laptop this badly, but oh well. No Chinese classes is a bonus for me :smiley:

So far so good, no frozen lockscreens yet. Had no issue removing Handwriting method, unlike @ideaman924, hehe.

Thanks @Andreas_Hegenberg for helping look into this issue for my MBP and its evil twin MBP belonging to Eric.

PS: No Chinese classes is a bonus for me too! :grin:

If you had enabled this Chinese handwriting stuff before Catalina it might be interesting to see whether adding it again now brings back the issue or not.

The posted samples look a bit like some conflicting settings in the handwriting tools are causing an endless loop - maybe their settings got corrupted during the update.

I will definitely take a closer look soon, however I’m quite busy until the end of next week, so it may still take me a while.

Alright, just had Handwriting tools re-enabled. Keeping my fingers crossed.

No worries @Andreas_Hegenberg, you take your time doing your other stuff... if it freezes again I'll just remove Handwriting Tools for now :slight_smile:

No luck on that front, I'm afraid - this Catalina install is a fresh one. I actually reformatted my laptop because I thought the upgrade had borked something and was causing issues with the lockscreen.

So if you're seeing some loop in the sample then it's a bug with Catalina, and not something I brought over with the upgrade from Mojave since this is a completely fresh installation with no Mojave traces.

Thanks for taking the time to look at the samples :smiley:

Just signed up to say, despite not being a BTT user (although I know it's cool) I have similar problems on my Catalina MBP,

xpcproxy[297]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port

I see the above message constantly.

I have a lot on the machine as it's a dev box, but running 10.15.1 didn't solve it.

Really annoying.

Also I notice crazy battery drops during sleep. I really want to know what the XPC issue is.

Also signed up to just say that i have this issue too. loginwindow chews CPU on sleep and is unable to wake. I have to SSH to kill loginwindow all the time causing a whole lot of other inconveniences on keychain access. Disabling BetterTouchTool solves the issue.

it will be great to get a fix. Thanks.

My machine seems to experience similar issue with interaction between BTT and Trackpad Handwriting. BTT ver. 3.206 (1382). Macbook Air Retina 2018

Syslog at time of login window freeze reports the following:

Nov 13 15:11:42 itachi syslogd[107]: ASL Sender Statistics
Nov 13 15:11:43 itachi xpcproxy[36922]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port
Nov 13 15:11:43 itachi xpcproxy[36923]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port
Nov 13 15:11:43 itachi xpcproxy[36924]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port
Nov 13 15:11:43 itachi xpcproxy[36925]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port
Nov 13 15:11:43 itachi xpcproxy[36926]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port
Nov 13 15:11:45 itachi logd[125]: Power button HID event - flushing proactively
Nov 13 15:11:51 itachi xpcproxy[36934]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port

*Update: After disabling trackpad handwriting issue has not reappeared since. It's been four days.

hey. signed up with a similar problem, also BTT and catalina

but: i have never used/enabled/disabled any handwriting tools! also, handwriting tools are not enabled, i checked.

it's a completely fresh install of catalina, hardly anything installed.

unfortunately, i am not sure what caused the issue exactly. i was setting up the touch bar, when the colored spinning wheel appeared, the system went more and more unresponsive, i could still move the mouse, but no access to any system functions, no checking or killing of processes possible. the fans sped up, the macbook was going very hot, so i decided to instantly shut it down. i looked at logs via console and found similar entries to the ones posted above.
it -may- have been caused by two things. either by connecting an external usb keyboard, or by putting the display to sleep, or by none of these actions. i cannot recall anymore.

in the logs, i noticed attempts to update the system or at least attempts to check for updates at the time of the crash.

this issue doesn't seem to be necessarily related to the handwriting tool. it seems its related to BTT on catalina, however.

are there any news?

thanks a lot

This sounds like a very different issue:-) why do you think BTT was related to your freeze?

because i was using the system for days without any problem and just after installing BTT and using it, this happened. also, when googling the system logs, it led me to this forum, where i found very similar (partly the exact same) log text lines
you say, it sounds like a very different issue - why? do you already have an assumption?