BetterSnapTool issue selecting text

When selecting text (tried Safari and Mail) in a window Snapped into place using a Snap area, the window sometimes jumps to a smaller/previous size and the Snap areas are displayed, as if I was attempting to drag a window. The window does not return to its old position, just to a smaller/previous size.

I tried disabling "Restore old size & position after doubleclicking again" under "Double-click a windows' titlebar", even though the option itself is not set up, but it makes no difference.

Using:
Macbook Pro (2018)
Touchpad
External secondary display (USB-C to DP)
MacOS 10.15.5
BST 1.9.3

Thanks for this otherwise great application!

Does no one else have this issue?

It seems to happen mostly or only in certain websites/areas. I have not tried to see if it happens with a mouse as well but with a touchpad using double-tap and drag it does happen regularly. It is very annoying.

Disable tap to drag function. Working for me

Thank you for your response.

If you are referring to the MacOS setting in system preferences, I don't want to disable this function because I use it very often. I you are referring to an option in BST, I can't find it.

It does seem to be a bug though, for one because it seems like unusual behavior with no upside to it, but also because it does not happen everywhere.

On 10.15 you might need to grant BetterSnapTool the screen recording permission in System Preferences-> Security & Privacy -> Privacy to prevent this issue

1 Like

That fixed the issue. Thank you.

Me being a bit stubborn, I disabled it again afterwards and the issue is still resolved, somehow, for now. Yes, the application has restarted after I disabled screen recording again.

Unfortunately that won’t last. Apple is blocking some necessary API‘s if the screen recording permission is not granted (see https://folivora.ai/blog/post/13011)

I was expecting it wouldn't last. Hopefully Apple will improve the permission options to allow for more specific permission granting.

Thanks for your support.

Hi,

Thank you for your respond. But this option don’t fix this issue for me. I still need to disable tap to drag function in btt.

Mac OS 10.15

Did you restart BetterSnapTool after enabling the Screen Recording permission?

I haven't heard of other things causing text selection issues so far.

When I active "Restore old windows size if.." go to browser. When maximized window and try select text - this happened. (I have enabling Screen Recording permissions and restart BTT) :slight_smile:

Imprint | Privacy Policy