AquaTouch -- Supports 40+ Apps, Websites, AND the Native TouchBar!

Since the script uses Javascript inside AppleScript (which is disabled as a security measure by default), this will not work. To enable this, you have to open Safari's preferences, click the Advanced tab, and enable 'Show Develop menu in menu bar' at the bottom. Once this is done, you have to open the Develop menu and click on 'Allow Javascript from Apple Events' (fourth from the bottom).

Once all of this is done, the navigation bar will magically start working.

Thanks for your contributions! They look quite useful though I'd need to review it first (while considering if it is useful for the wider audience).

Thank you also for the bug reports. @onaforeignshore's instructions might help you with that.

I'm not able to activley work on AQT as of now though, so it may be a while before your changes become a reality. Do keep me updated though.
For the Chrome Widgets, leave that to me, its quite a very interconnected feature with variables being written and read, window names and URLs being read, javascript and all kinds of stuff. Quite a complex thing. Thanks a lot for your work! I'll download your current mod to remember that its there but do keep me in the know if you update anything.

Thank you both for the replies.

Please find the latest version that I have updated today.

  • Quick tiling snapping global shortcut I added in the previous version is removed.
  • Chrome has major modification suited for my needs. Probably may not be so useful for wider audience.
    • Supports Google docs. It shows docs related buttons by default.
  • Aqua bug fix : Media control mode isn't working at the moment. I added 2 scripts for Chrome and Safari supporting Youtube.
  • Quick bug fix updating preset version to 3.5.1 from 3.5.0 (Unable to locate preset each other). I havn't tested gaming mode much. I probably won't play so much game on this laptop.
  • IntellIJ support
  • Station support
  • Control + Option opens Util tab showing weather forecasts, temperature and fan speed (istats needed).

Please find full description and pictures in the link provided above.

I am fairly happy with the current setup and try to get use to this setup from now. It would be great to fix media control group apps. however.

What I may add in future :

  • Add support for Notion app, but I will see how it goes and whether i feel the need to do that.
  • Chrome Youtube slider to change time from media control tab.

I will add any updates here if there is one.

2 Likes

Hi, Since 3.5.1, the MediaControlMode don't works as seamlessly as 3.5.0.

I use it mainly with Spotify and i'm no longer able to start/stop the song using long press on the MediaControlMode group button.

Also, when I'm in the group and I click next song, I can see the {"text":{"text"... with song name updating for a second before showing only the artist and song name.

I've tested back in 3.5.0 and theses 2 issues works fine.

Thanks for the bug report. Will look into it.



This update adds Web Widgets to Chrome and fixes some bugs that appeared on v3.5.1.


Download

Download at the AQT Downloads Thread! ➔


Changelog

Bug Fixes
New Features
Quality Improvements


@Dom:p
@dfrigon, try if this update fixes your issues.

AQT GitHub Repository Now Open!

See current progress, submit bugs and requests on github if you wish.

As the userbase for AquaTouch grows, it might get hard to keep track of bugs, suggestions and collaboration here.
I've taken some time to learn GitHub, and I find it is indeed a great way to handle development.

If you have a bug report, feature request or if you have created something useful for AQT, you can now choose between the forums here or by submitting an issue at GitHub!

I'll also be loosely logging progress there so you can follow along as to what i'm up to.

Note: I'm still moving in, so there might not be much there as of now. Gradually things will be added, but issues should work fine for now!

@Dom @onaforeignshore(I remember your "more regular updates" feedback)

Новый апдейт!

AquaTouch-b3.5.2 (RUS).bttpreset (30.0 MB)

Что нового:

  • Виджеты (Facebook, Youtube, Google - Таблицы, - Презентации, - Диск, - Gmail) теперь работают и в Chrome (изменилось сопряжение групп с приложениями).
  • На вкладке Play появлись кнопки быстрого управления Play/pause и След. трек для разных приложений
  • Новый виджет календаря во вкладке расписания и отображение вашего дока во вкладке приложения
  • Помимо жестов работают также удержание на кнопках яркости и громкости во вкладке настройки.
2 Likes

please add post localization to the topic

Thanks for the translate @ErmakOFF1990ya

I'm working on a languages topic and thinking about how it would work. Currently i have a lot on my hands though, so, sorry for the wait!

Y E S

1 Like

Hei man!! How are you? I'm so sorry for this late reply but I was away from my pc and I couldn't try latest realese! ...

I'm trying it for about 2 hours and this is what I noticed:


  1. Sometimes when AQT is closed, on the right side of the Touch Bar this BTT icon appears instead one of your preset ... Is it ok?

  2. https://photos.app.goo.gl/ATQjq5TY4LAkkWa6A

The new youtube widget bar seems it doesn't work


Everything else seems ok and works flawlessy!! :smiley: @yuuiko

Hi @Dom!
glad to see you again! you're one of the reasons why I keep going.

Youtube widget:

BTT button does show up for me too, I think its an issue with the new CS strip behaviours in BTT @Andreas_Hegenberg. Not sure exactly how to reproduce, will look out for it.

1 Like

I've been using the preset for a while, but only just made an account on the forum. Ever since updating to 1.5.2, my quick strip has been missing the media button that lets you play/pause things. Here's a screenshot to show you what I mean:

Beyond that, I guess now that I have an account it's my turn to award you with an obligatory compliment on the preset. I've had my eye on it since before I had a touch bar, so I'm not sure what the default even looks like. It is a totally viable replacement that fits into my workflow seamlessly. :​)

Hi @ANTIMONY!

Huh, never seen that one before..
Will look into it. Maybe a BTT restart helps?
I’m pretty sure I told it not to disappear when it gets an error...

And thanks so much for the encouragement! it makes creating this worth it. (may I use some lines from that in a promotional video?)

I already tried updating BTT and everything, but to no avail.

I'm sure this information is easy to find, but while I have your attention are you supposed to have the default preset enabled along with aqua touch or not? Both seem to have their own issues in the latest version and I can't remember how I had it set up before. :​P

And of course you can feel free to use anything I said. I'd love to help out any way I can even if it's just through words. And who knows? Maybe eventually I'll get around to figuring out how to modify the preset myself. It's something I've been meaning to do. :​)

Ideally it should be fine, but try disabling it and having AQT as master by itself.

It seems like BTT isn't updating the variable that the now playing widget reads.

Try reset all variables in BTT touchbar settings to try reboot the variables system. This will delete AQT variables though so remember your AQT settings. If you use pastecells in Atom or Script Editor, those will be reset too.

I've also just fixed the widget to handle this situation better.

After trying this it showed up for a split second then promptly vanished. Any clue why it would only be that button and none of the other 3?

I left an incorrect redundancy in the script of the QuickPlay button it seems, The other buttons have correct redundancies.

The core issue is that BTT doesn't seem to be updating the correct variables for you.
This is a BTT side issue, so uh... @Andreas_Hegenberg?

Meanwhile, you can insert this fixed script with correct redundancies into the script of the QuickPlay button:


--Thanks to @springles for his contribution to AQT!
--Posted: https://community.folivora.ai/t/1704/93?u=yyuuiko

try
	--@yuuiko: Get User Preference
	tell application "BetterTouchTool"
		try
			set UsrPref_CS_Highlighting to get_string_variable "CS_Highlighting"
		end try
	end tell
	
	if UsrPref_CS_Highlighting is "ON" then --@yuuiko: only activate if preferred by user.
		tell application "BetterTouchTool"
			try
				set showMediaControls to get_string_variable "BTTCurrentlyPlayingApp"
				set playerState to get_number_variable "BTTCurrentlyPlaying"
			on error
				return 0 -- Don't disappear on error
			end try
		end tell
		if showMediaControls is not missing value then
			if playerState is 1.0 then
				return 1 --Highlight
			else
				return 0 --Grey
			end if
		else
			if application "iTunes" is running then
				tell application "iTunes"
					try
						if player state is playing then return 1 --Highlight
						if player state is not playing then return 0 --Grey
					on error
						return 0 --Grey
					end try
				end tell
			else
				return 0 --Grey
			end if
		end if
	else
		return 0 --Grey
	end if
on error
	return 0 --if all else fails
end try

That didn't seem to fix it, so in an attempt to find the problem I hit the run button by the script and got this:

Any clue?

Imprint | Privacy Policy