AQT FAQ: Stuck Youtube Setup and Fix

I have this issue as well. No fix.

Running MBP 2016, 10.14.6 Mojave.

Hi @thomascanndrum!

Have you updated to the latest AQT?

Otherwise it might be a Mojave issue as I've only tested on Catalina

I have. Thank you for the this latest version. Since updating, this was the first time I’m seeing this issue or even the need to enable JavaScript etc. I can’t go to Catalina due to my profession being music plugins and DAW which are slow to catch on to how Apple handles storing data these days.

Hmm strange, enabling JS was always required, but maybe in previous versions there was no tutorial

Is your system and youtube in english and have you enabled JS in safari? Otherwise i've had issues with system language before.

I also don't recommend Catalina, It's been very troublesome for me honestly

Set to English. Not sure what's wrong to be honest. I'm trying to enable the scrubber and timeline. It redirects me to the "Setup youtube Widget". I've enabled develop in Safari and Javascript from Apple Events. I decided to go to youtube, enable javascript inspector, and attempt to use the widget. This is what I'm getting. I am by no means whatsoever a programmer. Maybe this is helpful. Maybe not.


Strange, Never had this issue before... Have you tried the below to make sure?

hi, this is also exactly what I have now.

  1. my touchbar shows this:

  2. even though my safari is setup

  3. I also removed disabled the Youtube Setup Wizard as you mentioned. But only the Picture in Picture buttons and enlarge video buttons work. The play/forward, scrubbing doesn't work.

BTT 3.346
Aquatouch v3.5.8a
Macbook Pro 16 Catalina 10.15.4, English

To add, the controls on this part works with YouTube. Play / pause works without problem

I had a similar issue with the setup widget. There are additional setup widgets in these folders you may also have to disable to get the message to go away.

The above steps worked fine! I have the scrubber and timeline again!


could you try pasting the following in terminal and tell me what shows up for me? (do them one by one

defaults read IncludeDevelopMenu
defaults read AllowJavaScriptFromAppleEvents

Ok, I did this again and realised you need to do step 5: File > Save Changes.

That did the trick for me.

Thanks for your help! I did went there and saw it was already disabled (??). Then I tried @yuuiko suggestion again, but found out I need to save it. Was that the trick, not sure. I did delete aqua touch and redownload it again to be sure, but it seems that it was still disabled for me (??).

could you try pasting the following in terminal and tell me what shows up for me? (do them one by one)

defaults read IncludeDevelopMenu
defaults read AllowJavaScriptFromAppleEvents

? Does not exist?

That's why it wasn't working for you.. I'm trying to make it more stable so thanks for your help!

If you don't mind could you try:

What macOS version are you running? e.g. Mojave, Catalina
and Safari version?
Also, what is your system language? e.g. Mine's in English


Make sure that "Allow Javascript from Apple Events" in safari is turned on again

Do in the terminal:

defaults read

Send over everything that comes out if you don't mind, maybe over PM or not at all if you're not comfortable. If you aren't then just explain what happened

It'll really help me make that setup widget more stable for others to use, thanks!

Screenshot 2020-04-17 at 14.48.20

Screenshot 2020-04-17 at 14.48.30

Screenshot 2020-04-17 at 14.48.54

It doesn't seems to like to output anything..... Does this have to do with SIP being enabled? (just a shot in the dark, I don't seem to understand anything what is happening here)

Thats very strange... especially the "safari does not exist" output

What I'm trying to do is read Safari's preferences to check if the Javascript from Apple Events is enabled, hence "defaults read"

It may be SIP, as mine is off i think... Ill try a few things then get back, such as enabling SIP / updating macOS if it isnt already updated

Maybe try restart safari / reboot macbook and see how it goes, otherwise you'll need to disable those setup messages manually for every update

I didn’t know about SIP until I installed virtualbox. It all behaved weird, like different kind of errors when installing guest OSs. It clearly looked like there was something random happening, like it wasn’t written for this version of macOS. Then turning of SIP all suddenly worked ok. I posted this on the virtualbox forum, it seems kinda of A black box. I am don’t know what SIP exactly does, but it did mess up their virtualbox compatibility.... so just my shot In the dark. Assuming most developers turn SIP off.....they might not notice the changes?

@narindo SiP is just another layer, quite a strict one, of protection in macos that prevents changing up the system too much. I think i have it off as it gets in the way of some of the things I do but it shouldn't effect defaults read commands...

I really have no idea why your terminal can't find Safari, I might ask the dev for some help with this

Anyway, do the youtube widgets work for you now?