Act as Hyper Key action missing

Hello. I have been using the Hyper Key functionality for some time without issue. Over the weekend it stopped working for no known reason. I tried to recreate the shortcut. I am able to map the caps lock key, however when I do so there is no 'Act as Hyper Key' action available.

The caps lock key is mapped to caps lock in macOS and functions as expected as a caps lock key. BTT does recognize the caps lock key when I try to create a keyboard shortcut. If I select something other than the hyper key action, the mapping is successful and works as expected for that action. I am using a standard Apple keyboard.

I have tried restarting BTT, I have tried removing and reinstalling BTT, I have tried some different versions of BTT, I have toggled the caps lock mapping in macOS back and forth a few times, I have removed all other keyboard shortcuts in BTT, I have tried deleting the caps lock shortcut from BTT, I have tried power cycling the keyboard, and I have rebooted. So far no change in behavior.

Does anyone have any other suggestions of what I might try? I am about out of ideas.


thanks for reporting, it should now appear again in 4.264 (uploading right now, will be available in ~10min)

Thank you. I upgraded to 4.265 and can now set the 'Act as Hyper Key' action. The keyboard shortcut shows that caps lock is mapped to the hyper key, however I have so far been unable to get caps lock to actually behave as a hyper key. The only thing that I am seeing is the usual caps lock behavior. If I map caps lock to another action (e.g. show desktop), it is both invoking that action and continuing to toggle caps lock in the usual manner.

I tried restarting BTT, recreating the mapping a few times, and eventually rebooting with no change in behavior. The caps lock key is still mapped to caps lock in macOS. I'm not running a beta; still on the latest version of Ventura.

1 Like

There was indeed an issue with freshly configured hyperkeys. This should now be resolved in 4.266

Thank you for the quick fixes. My hyper key is again functioning as expected.