2 Finger swipe left or right - cannot stop it in "All Apps" or InDesign

Am I missing something? No matter if I disable them in specific app InDesign or in All Apps it still operates in InDesign which is driving me crazy. This type of behavior is why I bought Better Touch Tool!

You mean two finger scrolling?
BTT currently doesn't have a way to turn scrolling off for specific apps. (But it's on my todo list)

Interesting because when I disabled 1 finger scrolling in indesign only it worked! But still - I tried to disable 2 finger scrolling in "All Apps" (though I really only care about it for indesign) Is "All Apps" where I want to go to disable 2 finger scrolling? If not; where and how do I do it?
Thank you for your response! I really need this to work!

As said, this is currently not possible, two finger swipes in BTT always refer to the two finger swipe gesture you can configure in BTT. It has nothing to do with system scrolling.